EMBOSS explorer

kdollpeny is not a valid EMBOSS application